Spesifikasi Web server untuk menjalankan CI 4

Tutorial

Sebelum mulai menggunakan Website BASIC maupun Website PLUS by DATAGOE SOFTWARE, kita harus menyiapkan alat yang dibutuhkan untuk menjalankan web site. Hal ini dilakukan karena Website ini menggunakan Framework Codeigniter 4.

Webserver

Berikut ini requirement server untuk Codeigniter 4:

  • PHP Versi 7.3+
  • MySQL Versi 5.1+
  • Phpmyadmin

Extension yang diperlukan:

  • intl extension 
  • mbstring extension.
  • php-json
  • php-mysqlnd
  • php-xml
  • libcurl (opsional)

Untuk pengguna windows dan XAMPP bisa langsung membuka file php.ini atau buka XAMPP Control Panel, lalu pada bagian apache klik Config->PHP.

Tampilan XAMPP Control Panel (Pengguna Windows)

Setelah itu, cari di bagian extension dan hapus ; yang ada di depan nama extension pada daftar diatas untuk mengaktifkannya. Contoh:

;extension=intl
// ubah menjadi
extension=intl
;extension=mbstring
// ubah menjadi
extension=mbstring

Setelah diubah simpan file dan restart webserver.

Pengguna Linux bisa langsung menginstall dengan command berikut ini:

sudo apt install php-json php-mysqlnd php-xml php-intl libcurl

Vian Taum

Sukses adalah sebuah PERJALANAN, bukan tujuan. Usaha sering lebih penting daripada HASILNYA..! -Arthur Ashe-

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *